Exchange-1

Exchange 2013 – Web Management Service doesn’t start

With Exchange 2013, you can have an issue where the service “Web Management Service” can not be started. Without it, you can’t install any Cumulative Update and some Exchange functionality are no more available.

Service not started

If you try to install a new CU, you get this error:

Error:
The following error was generated when "$error.Clear();
if (Get-Service WMSVC* | ?{$_.Name -eq 'WMSVC'})
{ Set-Service WMSVC -StartupType Automatic
Start-SetupService -ServiceName WMSVC
}
" was run: "Service 'WMSVC' failed to reach status 'Running' on this server."

When you look into the Service mmc and try to start manually the service, you get the error code -2147483640 :

Web Management Service Error

Web Management Service Error

Exchange Admin Center

This issue is due to a wrong manipulation in the Exchange 2013 Administration Center.  The SSL Certificate used by IIS Web Management Service was deleted. In fact, even if you don’t use this certificate, IIS do it. So do not delete it.

Exchange Admin Panel

Exchange Admin Center

Reset a new certificate

To resolve the problem, you must assign a new SSL certificate to the IIS Web Management Service.

  • Go to IIS – > Click on your Server -> Click on Management Service
IIS Management Service

IIS Management Service

  • Under SSL Certificate, select the new one. (You can use a existing certificate or recreate a new self-sign with IIS)
IIS Management Service Cert

IIS Management Service Cert

More

You could get more information about IIS Management Service here

Leave a Reply

Your email address will not be published. Required fields are marked *